Дисклеймер

Внимание: в этом блоге могут описываться события, явления и факты при помощи ненормативной лексики. Убедитесь, что Вы готовы к этому.

вторник, 1 октября 2013 г.

Установка МФУ (принтер + сканер) EPSON L210 в (K)Ubuntu

Дано: принтер EPSON L210 (МФУ с СНПЧ) и ubuntu/kubuntu 12.04 LTS.
Задача: сделать так, чтобы принтер и сканер заработали.

Драйверы можно взять вот здесь: http://download.ebz.epson.net/dsc/search/01/search/searchModule (потребуется выполнить поиск по модели L210).
Нам нужны epson-inkjet-printer, iscan и iscan-data последних доступных версий.

Пробуем установить драйвер на принтер:
sudo dpkg -i epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb
Получаем:
Выбор ранее не выбранного пакета epson-inkjet-printer-201207w.
(Чтение базы данных ... на данный момент установлено 123593 файла и каталога.)
Распаковывается пакет epson-inkjet-printer-201207w (из файла epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет epson-inkjet-printer-201207w:
 epson-inkjet-printer-201207w зависит от lsb (>= 3.2), однако:
  Пакет lsb не установлен.
dpkg: не удалось обработать параметр epson-inkjet-printer-201207w (--install):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 epson-inkjet-printer-201207w
Вот оно что. Ну хорошо, в таком случае,
sudo apt-get install lsb
Если установится сразу - хорошо. Но возможен и такой выхлоп:




 Чтение списков пакетов… Готово
Построение дерева зависимостей     
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 lsb : Зависит: lsb-core
       Зависит: lsb-graphics но он не будет установлен
       Зависит: lsb-cxx но он не будет установлен
       Зависит: lsb-desktop но он не будет установлен
       Зависит: lsb-printing но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).
Очевидно, что в таком случае сам apt рекомендует выполнить команду:
sudo apt-get -f install
Выполняем, а затем уже смело возвращаемся к первой команде:
sudo dpkg -i epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb
Как правило, проблем более не бывает (опыт установки на 5 системах). Ну а теперь дело за настройкой. Кому-то проще через панель настроек ОС, а наиболее универсальный метод - через веб-интерфейс CUPS.
Если кто (ещё) не знает, то этого можно добиться, перейдя в браузере по ссылке:
http://127.0.0.1:631/admin
 Ну и, собственно, картиночки (если какие вопросы возникнут) ниже:




С принтером разобрались, теперь на очереди сканер.

Для правильной работы драйвера сканера необходимо установить пакет xsltproc.
sudo apt-get install xsltproc
Ну а затем, собственно, установить сами пакеты с ПО для сканера:
sudo dpkg -i iscan-data_1.22.0-1_all.deb iscan_2.29.1-5~usb0.1.ltdl7_amd64.deb

Не забываем добавить себя в группы scanner и saned. Полагаю, это очевидно, что в Вашем случае вместо "ivan" нужно подставить имя учётной записи Вашего пользователя.
sudo gpasswd -a ivan scanner
sudo gpasswd -a ivan saned
На этом с установкой всё, можно сканировать через XSane и не только.
P.S. установка проводилась с XSane 0.998, в более поздних версиях принтер, теоретически, может быть подхвачен автоматически.

2 комментария:

  1. Большое спасибо. openSUSE 13.1 + Epson L210, http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX - YaST в настройках сканера, как и водится, предупреждает, что "может и не работать", но после установки iscan и iscan_data понадобилось только тыкнуть ему в L210. Еще раз спасибо.

    ОтветитьУдалить